Payment issue for French customers
Incident Report for Gandi.net
Resolved
This incident has been resolved.
Posted Apr 02, 2021 - 06:45 UTC
Monitoring
Our payment partner for French customers is currently unstable, the payment page is sometimes unreachable (timeout.)
Posted Apr 02, 2021 - 06:21 UTC
This incident affected: Portal (Billing / payments).