SSL incident create / renew / update
Incident Report for Gandi.net Status
Resolved
This incident has been resolved.
Posted May 14, 2020 - 14:49 UTC
Investigating
We are currently investigating this issue.
Posted May 14, 2020 - 13:28 UTC
This incident affected: SSL Certificates.