SoGo Webmail incident
Incident Report for Gandi.net
Resolved
This incident has been resolved.
Posted Jan 11, 2023 - 15:48 UTC
Investigating
We are currently investigating this issue.
Posted Jan 11, 2023 - 15:31 UTC
This incident affected: Gandimail (Sogo webmail).