Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 22, 2026 - 18:10 UTC
Scheduled
new .DK domain's registration is momentarily unavailable due to an emergency maintenance We expect the situation to be back to normal on Friday noon paris Time
Posted Jan 22, 2026 - 18:08 UTC
This scheduled maintenance affected: Domain name registration.