.fi domain operations unavailable

Incident Report for Gandi.net

Resolved

This incident has been resolved.
Posted Apr 17, 2026 - 13:00 UTC

Update

We are continuing to investigate this issue.
Posted Apr 17, 2026 - 12:01 UTC

Investigating

.fi operations are currently unavailable due to a technical issue with a third-party component.
.We are working to resolve this as a matter of priority and expect service to be restored shortly.
Posted Apr 17, 2026 - 12:00 UTC
This incident affected: Domain name registration.