Menu
Close
Gandi.net
Dashboard
x
Visit our
support site
.
Get the
Atom Feed
or
RSS Feed
.
emrgency maintenance on mail box
Incident Report for
Gandi.net
Resolved
This incident has been resolved.
Posted
Mar
13
,
2025
-
15:21
UTC
Identified
We are doing a maintenance on the admin portal, the mailboxes are temporarily not visible on the admin portal
Posted
Mar
13
,
2025
-
12:06
UTC
This incident affected: Portal (admin.gandi.net).
×
Subscribe to Incident
Subscribe to updates for
emrgency maintenance on mail box
via . You'll receive .