Menu
Close
Gandi.net
Dashboard
x
Visit our
support site
.
Get the
Atom Feed
or
RSS Feed
.
Mailbox incident
Incident Report for
Gandi.net
Resolved
This incident has been resolved.
Posted
Sep
09
,
2024
-
13:07
UTC
Investigating
We are currently investigating this issue.
Posted
Sep
09
,
2024
-
07:38
UTC
This incident affected: Email (Access (IMAP/POP3)).
×
Subscribe to Incident
Subscribe to updates for
Mailbox incident
via . You'll receive .