Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 03, 2025 - 12:00 UTC
Scheduled
We are planning migration on some mailboxes in order to enhance their performance. You may experience some issues connecting to your mailbox during a small time window during the migration process, we invite you to wait and retry after a couple of minutes if you are in such a situation.
Posted Apr 03, 2025 - 09:49 UTC
This scheduled maintenance affects: Email (SMTP in, SMTP out, Roundcube webmail, Sogo webmail, Access (IMAP/POP3)).